← Back to results
Vulnerability record · public intelligence
CVE-2025-68953
HIGH

Certain Frappe requests are vulnerable to Path Traversal

Published Jan 5, 2026 · Updated Oct 23, 2026

Severity · CVSSHIGH · 7.5
Known exploitationNot listed
EPSS / likelihood0.43%
QFinch risk score10 / 100

Original summary

Normalized public record · Updated Oct 23, 2026

Certain Frappe requests are vulnerable to Path Traversal

Publisher and source text is retained separately from QFinch interpretation.

QFinch assessment

Frappe is a full-stack web application framework. Versions 14.99.5 and below and 15.0.0 through 15.80.1 include requests that are vulnerable to path traversal attacks. Arbitrary files from the server could be retrieved due to a lack of proper sanitization on some requests. This issue is fixed in versions 14.99.6 and 15.88.1. To workaround, changing the setup to use a reverse proxy is recommended.

Evidence: public source records

Affected products

Affected scope reported by the available public evidence
Affected package, product or rangeFix status
Consult the referenced vendor advisory for affected versions.Consult source advisory

Matching a version is only one part of assessing exposure. QFinch has not assessed your environment on this public page.

Remediation

Apply the vendor-supported fixed release or mitigation, then verify the affected component is no longer reachable.

  1. Confirm the affected product and reachable code path exist in your environment.
  2. Apply the vendor-supported patch or mitigation from the primary advisory.
  3. Rescan the exact deployed revision and retain verification evidence.
Review primary references

Evidence coverage

CVENVDEPSS
SSVC priority
MEDIUM
Confidence
10%
Aliases
None reported

Scores appear only when corresponding evidence exists. Missing data is never interpreted as zero risk.

Sources and record history

  1. Security advisory ↗
  2. Patch commit ↗
  3. Patch commit ↗

Record history

Published Jan 5, 2026 · Last refreshed Oct 23, 2026