← Back to results
Vulnerability record · public intelligence
CVE-2025-59944
HIGH

Cursor IDE: Sensitive File Overwrite Bypass is Possible

Published Oct 3, 2025 · Updated Oct 24, 2026

Severity · CVSSHIGH · 8.0
Known exploitationNot listed
EPSS / likelihood0.51%
QFinch risk score10 / 100

Original summary

Normalized public record · Updated Oct 24, 2026

Cursor IDE: Sensitive File Overwrite Bypass is Possible

Publisher and source text is retained separately from QFinch interpretation.

QFinch assessment

Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.

Evidence: public source records

Affected products

Affected scope reported by the available public evidence
Affected package, product or rangeFix status
Consult the referenced vendor advisory for affected versions.Consult source advisory

Matching a version is only one part of assessing exposure. QFinch has not assessed your environment on this public page.

Remediation

Apply the vendor-supported fixed release or mitigation, then verify the affected component is no longer reachable.

  1. Confirm the affected product and reachable code path exist in your environment.
  2. Apply the vendor-supported patch or mitigation from the primary advisory.
  3. Rescan the exact deployed revision and retain verification evidence.
Review primary references

Evidence coverage

CVENVDEPSS
SSVC priority
MEDIUM
Confidence
10%
Aliases
None reported

Scores appear only when corresponding evidence exists. Missing data is never interpreted as zero risk.

Sources and record history

  1. Security advisory ↗

Record history

Published Oct 3, 2025 · Last refreshed Oct 24, 2026