← Back to results
Vulnerability record · public intelligence
CVE-2019-11253
HIGH

XML Entity Expansion and Improper Input Validation in Kubernetes API server

Published Oct 17, 2019 · Updated Nov 3, 2026

Severity · CVSSHIGH · Not scored
Known exploitationNot listed
EPSS / likelihood25.94%
QFinch risk scoreNot available

Original summary

Normalized public record · Updated Nov 3, 2026

XML Entity Expansion and Improper Input Validation in Kubernetes API server

Publisher and source text is retained separately from QFinch interpretation.

QFinch assessment

Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.

Evidence: public source records

Affected products

Affected scope reported by the available public evidence
Affected package, product or rangeFix status
Consult the referenced vendor advisory for affected versions.Consult source advisory

Matching a version is only one part of assessing exposure. QFinch has not assessed your environment on this public page.

Remediation

Apply the vendor-supported fixed release or mitigation, then verify the affected component is no longer reachable.

  1. Confirm the affected product and reachable code path exist in your environment.
  2. Apply the vendor-supported patch or mitigation from the primary advisory.
  3. Rescan the exact deployed revision and retain verification evidence.
Review primary references

Evidence coverage

FIRST-EPSSCVE-LIST-V5
SSVC priority
MEDIUM
Confidence
Not available
Aliases
None reported

Scores appear only when corresponding evidence exists. Missing data is never interpreted as zero risk.

Sources and record history

  1. GitHub advisory ↗
  2. CVE-2019-11253: denial of service vulnerability from malicious YAML or JSON payloads ↗
  3. RHSA-2019:3239 ↗
  4. security.netapp.com ↗
  5. RHSA-2019:3811 ↗
  6. RHSA-2019:3905 ↗

Record history

Published Oct 17, 2019 · Last refreshed Nov 3, 2026